Tuesday, November 20, 2012

How to install ionCube loader on Ubuntu 12.04

Some CMS (content management systems) may require IonCube Loader which is a PHP extension to encode PHP files.

The extension is not in the Ubuntu repos, so you'll have to grab it from the developer's website. (http://www.ioncube.com/loaders.php).

Here is how to install IonCube Loader on Ubuntu 12.04 (and other releases and editions of Ubuntu as well).

If your Ubuntu system / server is 32-bit:

cd /usr/local
sudo wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gz sudo tar xzf ioncube_loaders_lin_x86.tar.gz

If your Ubuntu system / server is 64-bit:

cd /usr/local sudo wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz sudo tar xzf ioncube_loaders_lin_x86-64.tar.gz

Next step is to check if PHP loads the extension:

echo "zend_extension=/usr/local/ioncube/ioncube_loader_lin_5.4.so" | sudo tee /etc/php5/conf.d/ioncube.ini

Then restart the webserver:

sudo service apache2 restart

That's it.

4 comments:

  1. Hey there.

    You need tot check your php version with the "php -v" command, and then use the appropriate ioncube_loader_lin_5.x.so

    ReplyDelete
  2. thanks...
    http://rumahict.com

    ReplyDelete
  3. You should also note that this extension must be loaded before other zend extensions, else server will fail to restart.

    ReplyDelete